1.0 Objective
The objective for this tutorial is to create a small, quality controlled, database and a small database, with known errors, for use in testing AFL functions and procedures.

1.1 Introduction
Small databases, with a limited number of symbols and limited data, can be useful for solving complex problems, or designing systems within AmiBroker. They can be easier to use, for debugging code or proving strategies, than larger databases. They are especially useful for manually cross-checking formula results, or when exporting data for cross-checking in spreadsheets.
The profile required depends on the tests being conducted. As a rule of thumb allow enough data to display comfortably in a chart window, plus the number of bars required for calculating indicators e.g. for a 25 bar Moving Average allow 25 bars for calculation plus 40-50 bars for display. For weekly or monthly testing multiply daily bars by 5 or 22 respectively to reach an approximate estimate of the number required for downloading.
For most situations two types of testing database are sufficient; a quality database without any quote errors and a database with controlled or known errors. (Note that the AFL testing databases are primarily intended for training use and not back-testing. While similar database management techniques apply, back-testing databases require much larger amounts of data. However most of the recommended methods are worth adopting for use with all databases).

2.0 Managing Databases
Sometimes it is necessary to cross-check a test, or return to it a later date for further development. Careful management of databases is required to allow for repeatability. Testing databases should be backed-up and quarantined from every day databases to prevent data corruption. (Note that Yahoo historical data may change over time due to split or dividend back adjustments so it may not be possible to reproduce previous test conditions with a new download, even when the original date range is used).
This section provides some tips for managing databases in an effective way.
1.1 Database Naming Conventions
Adopting clear naming conventions for databases can help prevent errors.

For users who want to retain the AmiBroker folder structure as installed, it is easier to manage large numbers of databases by saving them with the prefix Data_ e.g. Data_DJIA. All data folders named in this way are then arranged together alphabetically near the top of the folder tree.
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1.2 Database Management Tools
There are several tools available to manage databases, both from within and without AmiBroker: 

1.2.1 Windows Explorer

The operating system file manager, or utilities like Windows Explorer, provide a means to manage all database tasks. The obvious disadvantage is that      these programs are external to AmiBroker. Also the default view, each time these tools are opened, requires unfolding the full hierarchical path to access the AmiBroker folder. 
If Windows Explorer is to be used frequently a short cut can be added to the desktop rather than walking through the hard drive folders. 
To add a shortcut to AmiBroker to the desktop:

a) open MyComputer,

b) expand the folder tree to C:\Program Files\AmiBroker,

c) right click on AmiBroker,

d) select Send To > Desktop (create shortcut) from the context menu that opens. 
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Clicking on the ‘Shortcut To AmiBroker’ icon, that is installed on the desktop, will take the user straight to the AmiBroker folder, making all the Data_ folders stored there available.
To remove the shortcut at any time:

a) right click on it,

b) pick Delete from the context menu that appears,

c) select Yes when asked to Confirm File Deletion.
1.2.2 The Browse for Folder Window
The quick way to open databases is to do it from the ‘File’ menu ‘Open Database’ command within AmiBroker. The disadvantage of this tool is that the full range of task management commands is not available. Databases can not be copied, renamed or deleted from there. The ‘Program Files\AmiBroker’ folder is always the default when this window is opened. This method suits those who choose to save their databases within the AmiBroker program folder as it takes the user straight to the Data folders.
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1.2.3 The Open Window

Databases can also be opened from ‘File’ > ‘Open’ on the AmiBroker menu bar, by browsing to the database, opening the folder and double clicking on the broker.workspace file that is stored there. Database folders can be copied, renamed and deleted from within this window. It is the best option available for quick access to all database management functions. The default for the ‘Open’ window is the last folder where a database was opened, so this method offers advantages to those who maintain databases in any folder, including those outside of the Program Files\AmiBroker group.
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1.3 Backing Up
It is advisable to backup valuable database files. They should be saved under a name that readily identifies them, and quarantines them from future downloads. Any hard drive location can be used, but an external or partitioned drive is the best option.

For this example a quality checked database with a low error count is required, as it will be used to produce other AFL testing databases.

The procedures described in the Users’ Knowledge Base article ‘Example Database’ should be used to check the example ‘Data’ database. It is assumed that this has been done and that the original database, as installed, has been saved as ‘Copy of Data’.
To make a second copy of ‘Data’ in the AmiBroker folder:

a) go to AmiBroker > File > Open,
b) click on the My Computer icon and browse the folder/file lists to C:/Program Files/AmiBroker,

c) right click on Data and pick Copy from the context menu that appears,
d) right click in white space in the Open window and click on Paste.

‘Data’ will be reproduced in the folder as ‘Copy (2) of Data’.

To rename ‘Copy (2) of Data’ to ‘Data_Quality’ in the AmiBroker folder:

a) right click on Copy of (2) Data and pick Rename from the context menu (the folder name will then be highlighted in a textbox),

b) hit Delete to clear the old name, 

c) type Data_Quality into the text box and then click in white space to save it.

To backup ‘Data_Quality’ to an external drive (G):

a) right click Data_Quality,
b) pick Send To Local Disk (G:) from the context menus.

[image: image5.png]Lok [ ke

My Recent
Documents

Deskiop

=]

My Docurents

My Computer

Q

My Network
Places

(Soamicuote
oy o Data
S0t
Eoata_cualig
(EFomts
SFormias
Citarouts
Sotites
SPhugins
Saserts

File name:

Files of type:

Select

Open
Explore

Scan Directory with eTrust PestPatrol
Scan Directory with PestPatrol
Search,

Sharing and Secury.
Scan

d:

copy
Paste

Create shartcut
Delete
Rename

Propertiss

O (£ compressed (zipped) Folder
(2 Destiop (create shortcut)
2 Mail Recipient
(53 My Documents
14 3% Floppy (8:)

2 CoRW Drive ()





2.0  Create A Quality Testing Database

Returning to the tutorial objective, the first step is to make a small database with a few symbols that have no data errors at all.

Data_Quality provides a base that can be used for this purpose, by selecting symbols from it that have no data errors for the test range under consideration.
2.1 Open Data_Quality
To open ‘Data_Quality’:

use the AmiBroker > File > Menu > Open path to find and open the Data_Quality folder,

select All Files (*.*) from the Files of type dropdown list,

click on broker.workspace in the file list,
open it using the Open button.
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2.2 Check The Location Of Errors
Use AmiBroker’s Database Purify Tool to Analyse Data_Quality and find the exact location of any remaining errors.
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This database is suitable for creating small databases, provided that AA and GE are not included in downloads that start before August 5th 2005.
2.3 Create A New Database

The latter stages of this example require a database with an index, for reference, and four symbols with a small amount of data. As the date range will not exceed the 8/5/2005 limit any four symbols can be chosen. (In this case AA, AXP, BA and C have been used as the author originally worked with the ^DJI database as installed and chose the first four symbols from that database. The same symbols have been picked again as files saved at that time will be used in future Users’ Knowledge Base tutorials).
To setup a new database in AmiBroker:
a) go to the menu bar and  select File > New  > Database (the Database settings window will open), 

b) enter the name Data_TestQuality in the Database folder path and click on Create,
c) accept the default settings by clicking OK. 
(There is no need to use the advanced options; Flush cache, Intraday settings or Configure in this example).
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This creates a blank database i.e. it has no symbols and no data. Note that the database name and file path is in the bottom right corner of the window (provided the status bar is enabled). Hover over the name in the status bar to open a callout box that lists basic details about the current database.
(If the status bar is not present click on View > Toolbars > Status Bar to turn it on).
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2.4 Download Limited Data

As a specific and limited amount of data is required for this database, AmiQuote should be used in preference to downloading from within AmiBroker.

To download data:

a) leave AmiBroker open at the Data_TestQuality database and open AmiQuote,
b) use AmiQuote to download data for AA, AXP, BA and C for the date range 8/15/2006 – 9/14/2006. 
For those who are uncertain about this, the procedure is explained in the Users’ Knowledge Base article ‘Example Database’, section 2.42 

(Once again the dates chosen have no particular relevance other than that they were used by the author on a previous occasion and the author has saved copies of the database and AmiBroker examples derived from it).
If the AmiQuote download is started with AmiBroker closed a warning message will popup.

If this situation occurs:

a) open AmiBroker,

b) open the database that the download is intended for e.g. Data_TestQuality,

c) click OK in the Quote message box.
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The download is a one step process, with AmiQuote’s ‘Automatic import’ entering the symbol list into the blank database, along with the data. 

When the download is complete run a quality check using the tools discussed in the Users’ Knowledge Base article ‘Example Database’.
It can be seen that 22 bars of daily data, from 8/15/2006 – 9/14/2006 inclusive, have been downloaded for each symbol with no quote errors.
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If the Database Purify tool is run on Data_TestQuality it comes up with a blank.
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2.5 Backup Data_TestQuality
Now that Data_TestQuality has been created and checked it should be backed up to a safe drive, using the procedure detailed in section 1.3 above.
3.0  Create A Testing Database With Controlled Errors

The quality testing database can be used as the starting point to create a testing database with known errors.

There are four possible types of error considered in this tutorial; extra quotes at the beginning of symbol data and missing quotes at the beginning, middle or end. Data_TestQuality contains four symbols, as well as the reference symbol, to provide for each type. Data can be manually added to or deleted from each symbol to produce an example of each error on a symbol by symbol basis. As a starting point Data_TestQuality needs to be duplicated as Data_TestErrors.
3.1 Create A Data_TestErrors Database

To duplicate Data_TestQuality:
a) create a New >  Database called Data_TestErrors (this will be a blank database i.e. empty folder, as it will contain no symbols or data).
b) open Data_TestQuality from the recently used files list at the bottom of the AmiBroker > File dropdown menu,

c) use Save As or Save Database As from the same menu and pick Data_TestErrors from the folder list.
3.2 Add Quote Errors To Data_TestErrors

3.2.1 Add An Extra Quote To AA

To add an extra quote to AA:

a) select it from the All Symbols list and open the Quote Editor,
b) use Current symbol/all quotes, which is the default mode,

c) click on the Date column heading to sort it in reverse order, (this will bring the start date for the series to the top of the list), 
d) click on (new) in the top row of the quotes list (the data entry boxes which were previously locked will now become editable),
e) type 8/14/2006 into the Date box, or use the calendar available from the drop down to select this date,

f) enter any arbitrary price in the Close input box 

(As the extra quote has only been included as a demonstration, and will be ignored in future examples, it is not necessary to maintain absolute accuracy.  In this example 28 has been chosen as the nearest integer to the next close price. Users who want to maintain strict accuracy can reference the actual OHLCVOI values for AA on 8/14/2006, from Data_Quality, and enter them instead of an arbitrary number.),
g) click in any row.
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The database will be updated with the new input and the window will remain open for checking the results or making further entries. (Note that if ‘OK’ is checked the values will be updated but the window will close).
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3.2.2 Delete Quotes From AXP, BA & C
To delete quotes from AXP:

a) open Quote Editor with AXP as the selected symbol,
b) reverse sort the Date column,

c) select the first 8 rows by clicking on the first row and holding down the shift key while clicking on the eighth row,
d) then use Delete to remove the selected data.
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Repeat the process in a similar way for:
a) BA - delete two days in the middle of the price series; 8/18/2006 and 9/1/2006,

b) C - delete the last three days; 9/12/2006, 9/13/2006 and 9/14/2006.

(As before there is no particular rational for the dates chosen except that they replicate a pattern used by the author elsewhere).
3.3.3 Visually Confirm The Results

It is helpful to use some visual aids to confirm the results.

Run a quality check on Data_TestErrors.
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Run the Database purify tool.
The results can be copied from within a context menu by right clicking in any row.
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From there they can be pasted into Word to allow for printing and comparison to the values in Quote Editor or in any other program where the data is  used.
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(Note that the errors are all reported relative to the reference Index. The terminology provides some clues as to the nature of the error. The term ‘extra quote’ specifically refers to a quote that starts before the first bar of the referenced index. ‘Missing quote (shorter history)’ refers to missing quotes at the start of the price series while ‘Missing quote’ is used for bars that are missing from the middle or end of the series).
If the values from Data_TestError are entered to a spreadsheet the error pattern can readily be seen. Extra quotes and missing quotes are highlighted in yellow.
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(Note that the spreadsheet image is for example use only. It is from an earlier test conducted by the author and the values do not match those downloaded in this tutorial).
3.4 Backup Data_TestErrors.
Now that Data_TestErrors has been created and checked it should be backed up to a safe drive, using the procedure detailed in section 1.3 above.

4.0 Example
A simple but effective use for AFL testing databases is as a visual aid when learning about some functions or variables.
BarCount and BarIndex() produce very similar, but distinctly different outcomes, when used in AFL. For new users this distinction can be difficult to understand. A simple comparative plot of each can help.
To compare BarCount and BarIndex(), insert the following two formulas into a chart in Data_TestQuality and scroll through the symbols using the up/down arrows on the keyboard. The values for each bar can be also be read from the chart title by scrolling the Selector Line from bar to bar using the left/right arrows. (Refer to section 1.1.2 from the Users’ Knowledge Base article ‘Example Database’ for details on using formulas in AmiBroker).
/*P_BarCount*/
Plot(BarCount,"BarCount",1,1);

/*P_BarIndex()*/
Plot(BarIndex(),"BarIndex",1,1);
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The exercise can be repeated with Data_TestErrors. (As expected the BarCount for each symbols is ‘as reported’ by Exploration checking in section 2.4 and 3.3.3 of this tutorial). 
The difference between BarCount and BarIndex() can be readily seen; BarCount is the total count of all bars, and hence it is a constant, while BarIndex() is a progressive bar count that starts from zero. For that reason the last value of BarIndex() is always one less than the BarCount.
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The value of the AFL testing databases, in this example, is that the number of bars can be manually counted and compared to the plots and also the previous database checks. This helps understanding and builds confidence in AFL and AmiBroker.

Note: Obviously this is not a great example, but in other cases, small testing databases are worth their weight in gold in simplifying code writing and testing. 

5.0 Conclusion

This completes the tutorial. Data_TestQuality and Data_TestErrors have been created and backed up. (Note that this is a basic example, primarily intended to act as a training exercise, however, Data_TestQuality and Data_TestError, or similar small databases produced in the same way, will be featured in future Users’ Knowledge Base articles). Those who followed this tutorial have the option of saving the new databases for future use or deleting them.

APPENDIX

Prerequisites
‘Example Database’, which is the first tutorial in this Users’  Knowledge Base series, is recommended as a prerequisite for this tutorial.
Word Settings

The default view for this document is Normal/Document Map, with the toolbars disabled.

To set the document to the default view:

a) pick View > Normal from the Word menu bar,

b) check Document Map by clicking on it.

To disable the toolbars use View > Toolbars to uncheck selected toolbars e.g. Standard, Formatting.
To restore the document to Normal View:

c) uncheck Document Map by clicking on it.

To restore toolbars use View > Toolbars to select which toolbars to show e.g. Standard, Formatting.
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