Objective

The objective for this tutorial is to make a backup copy of the ^DJI example database installed with AmiBroker, check the working database for quality and refresh it if necessary. The techniques demonstrated have wider application and can be used to manage other databases, including larger ones. 
Introduction
Default Database

By default, AmiBroker opens after installation with an example Dow Jones Index (^DJI) database comprising 30 symbols and approximately 2 years of daily price data. (Note that ^DJI is the Yahoo symbol for the Dow Jones Industrial Average (DJIA). The symbol used may vary between data providers).
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Data from  http://finance.yahoo.com/ is automatically installed, during the set-up process, in a local database folder named ‘Data’. 

The ‘Data’ folder is in the C:\Program Files\AmiBroker\ subdirectory or it’s equivalent. It contains alpha-numeric folders, for storing data, plus a layouts folder and three broker files. Refer to ‘AmiBroker Help > Help Contents > Technical information > Files used by AmiBroker’ for details on the function of each.
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A basic profile of each company is also included in the set-up. 
Details can be viewed on a symbol by symbol basis:
a) click on the Information tab in the Workspace to the left of the charts. 
b) if the Information tab is not visible check the Symbol Information option in the View menu.
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Profile information for symbols that are deleted from the database will be lost and can not be restored easily. New symbols entered to the database will not have profile data included. As symbols will be deleted and added during this tutorial it is recommended that a backup copy of the database is made.
To allow for restoration to the original set-up, following this procedure, save the ‘Data’ folder as a copy:

a) open Windows Explorer and expand the hierarchical tree to C:\Program Files\AmiBroker,

b) right click on ‘Data’ and Copy from the context menu that opens,
c) right click white space adjacent to the copied folder and select Paste.
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To restore the installed database as the default:

a) right click on ‘Data’ and Delete it from the context menu,
b) right click on ‘Copy of Data’, select Rename and replace ‘Copy of Data’ with ‘Data’..
Alternatively to use the orginal database as installed while retaining the updated version:

a) go to AmiBrokers menu bar  and select File > Open Database,

b) and pick the ‘Copy of Data’ folder from the browser list to open it. 
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       c)  then make ‘Copy of Data’ the default database by going to Tools > Preferences > Data and Picking it as the Default database path.
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Symbol Lists

The list of symbols that comprise the database is in an AmiBroker specific file, DJIA.tls, in the C:\Program Files\AmiBroker\AmiQuote subdirectory.
All .tls files are associated with AmiQuote and if opened they will run with AmiQuote in download mode.
AmiQuote data downloader is a subsidiary program of AmiBroker and can be manually opened from the operating system program menu. 
The DJIA.tls file can be copied and renamed as a .txt file, provided the filenames are using extensions. DJIA.txt can be opened, read and edited in Notepad or any plain text editor.
To show file type extensions:
a) go to Windows taskbar start > Control Panel > Appearance and Themes > Folder Options,

b) select the View tab,

c) under Advanced Settings uncheck the ‘Hide extensions for known file types’ box.

To copy and rename Djia.tls:

a) in Windows Explorer go to C:\Program Files\AmiBroker\AmiQuote, 

b) right click on Djia.tls and select Copy from the context menu,

c) right click white space in the same pane and Paste,

d) right click ‘Copy of Djia.tls’ and select Rename,
e) replace .tls with .txt in the text box that appears.
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The Download folder contains data files  for all symbols that have been updated using Amiquote. The downloaded data is stored here before exporting it to AmiBroker.
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1.0  Check The Database Quality

Irrespective of the data provider, it is the norm for equity price series to have days where no data is available i.e. there may be missing quotes in the price series. AmiBroker provides means for users to manage missing quotes, however, when testing code it is better to use data with all quotes available. For this reason it is advantageous for users to check the quality of the example database and improve it if possible.
1.1 Check All Quotes
1.1.1 Run The DataBase Purify Tool

The database can be quality checked using a built-in tool:
a) from the menu bar select Tools>Database Purify to open the Database Purify Tool,
b) enter ^DJI as the Reference symbol, check all optional tick boxes, and Analyse data quality for All symbols and All quotes.
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In this example a lot of problem quotes have been reported for the database. This number of data errors can make it difficult to know where to start the data cleanup process.
1.1.2 Create A Formula File
A simpler means of estimating the size of the clean-up task is provided via an exploration:
a) open Formula Editor from the Tools Toolbar,            
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b) copy/paste or type the following code into a blank Formula Editor page, run a Verify syntax check and Save it as X_Database.
/*X_Database*/
Filter = 1;

AddColumn(BeginValue(DateNum()),“StartDate”,1.0,1);

AddColumn(LastValue(DateNum()),“EndDate”,1.0,1);

AddColumn(BarCount,“BarCount”,1.0,1);

//AddColumn(Status(“stocknum”),“Stocknum”,1,1);
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The formula will be saved in C:\Program Files\AmiBroker\Formulas\Custom as an X_Database.afl file. It will appear, alphabetically listed, in the Custom folder within AmiBroker’s Charts pane. (The last line of code provides an option for an ordinal count of the symbols in an Explored list).
1.1.3 Run An Explorer Check

Once the formula has been saved it can be used to compare the number of bars stored in the database for each symbol:
a) open Auto-Analyser from the Tools Toolbar,                   
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b) Pick X_Database from the C\Program Files\AmiBroker\Formulas\Custom folder,
c) Explore all symbols for n last quotations with n = 1.
The Backtester settings and other options don’t apply to an Exploration.

The output can be viewed in the Results pane:
a) click on the Title row to sort the column by BarCount, 
b) compare the number of bars and the start-end dates for each symbol to ^DJI, which is assumed to be correct. 
(The date is in the format returned by the DateNum() function i.e. 1070118. Removing the first digit, which is padding, leaves 070118 in the format  YYMMDD i.e. 2007 Jan 18th.) 
Six symbols have significantly less data and different range dates to the referenced index. 
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2.0 Update The Database
2.1 Update Quotes

2.1.1 Auto-Update Quotes
The number and quantity of errors in the database as it stands is unacceptable and an update is required. The first place to start is to download quotes for all symbols up to the present:
a) select Tools>Auto-update quotes (AmiQuote only) from the AmiBroker menu bar. (The pre-requisite is that Yahoo Historical must have been selected as the data source last time AmiQuote was used),
b) alternatively AmiQuote can be opened, Yahoo Historical selected as the source and Auto-update AmiBroker database selected from the AmiQuote toolbar.
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                                  click here [image: image15.bmp]        
Note that at the end of the download all symbols have been updated except for SBC whose status is ‘Error during download. Yahoo! – 404 Not Found. Either the symbol is incorrect or there is a problem with the data vendors site’. 
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2.1.2 Re-Run An Explorer Check
After the database has been updated repeat the X_Database Exploration. 
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All symbols, except for SBC, now have the same date range and BarCount as ^DJI. A decision has to be made whether to keep SBC in the database and repair it, or, alternatively, delete it. This requires an individual check of the status of SBC.

AmiBroker has a useful feature in that other modes are still accessible while the Automatic Analysis window is open. This can be used to visually confirm that SBC has a different range of quotes to the other symbols:
a) leave the AA window open,
b) click on SBC in the All symbols list, to bring up the SBC chart in the background, 
c) select the last bar in the chart and read the date read from the chart title,

d) compare the actual date for the first or last bar to those reported by Explorer.
This confirms that SBC only has data up to 2005 Nov 30th  (1051130) which suggests that it is no longer a member of the DJIA, or it has had a name change.

A background Chart check can also be made via the Results list:
.

a) tick Sync chart on select in the AA window,
b) click once on SBC in the results pane ticker list. 
(In this mode, charts for all symbols in the results list can be scrolled through using the up/down arrow key).
. 
To provide a better view the results pane can be changed to a standalone window by toggling the up/down arrow in the uppermost right hand corner.

2.2 Delete Symbols With Missing Quotes
A check on the status of SBC can be carried out at the finance.yahoo.com (Y!F) site from within AmiBroker:
a) from the menu bar open New > Web Research and a new tabbed window will open at the AmiBroker default Web page,
b) go to Tools > Customize > Web Pages (Tab), 
c) click on Profile (Y! Finance) and then use the Move Up button to move it to the top of the list. 
This will make this page the default and Web Research will open there each time a new Web page is called.
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The Web Research Y!F window can be synchronised with the symbol that is current in the All Symbols list:
a) select Sync active from the Web Window Toolbar,
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b) Click on SBC in the All Symbols list, if it is not already the active ticker.
SBC is reported as an invalid ticker symbol.
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As the database is for example use only, SBC can be deleted. 
a) Right click on SBC in the All symbols list.

b) Select Delete from the context menu that appears.

2.3 Delete Extra Quotes
A final check should be made on the remaining symbols.

Use the database purify tool to analyse all the stocks in the database again. In this case there are now only four reports of quote errors, which is a much better result than the initial check.
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However, it is important to remove all extra quotes from any database, as they are out of alignment with the reference symbol and the majority of other symbols. In this example AA and GE require attention:
a) select AA in the All symbols list, 

b) then open Quote Editor from the Standard Toolbar,
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c) click on the Date title to sort the date column by reverse order, 
d) select the 9/8/2004 row, 
e) Delete the row, 
f) repeat this process for GE.
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If the Database Purify Tool is re-run only two errors will now be reported from the total number of bars in the database i.e. 29 * 671 bars = = 19459.

This is a reasonable outcome.
‘Data’ can now be used as a code testing database according to the user’s requirements. 

2.4 Refresh The Index Components List
For some purposes a database with updated components might be preferred.

3.4.1 Delete Obsolete Symbols
To refresh the Index start by obtaining a current components list from Yahoo!Finance:
a) open the Profile (Y!Finance)  Web Research window in Sync mode, 
b) click on ^DJI in the All Symbols list, 
c) select Components from the web page side bar to open the page.
[image: image1.png]s AmiBroker - ["DJI - DOW. JONES INDUSTR - Daily]

(d Bl Edt Vew Insert Formet Symbol Analysis Toos Window Help

DEEE & ®0 em, o e GABL 24D,

Symbols RO X | (3 ~ow (aiy) =
Symbols | Layouts | Lavers | Charts | 90 7T Dally 0572007 Open 13300.4, HI 13359, Lo 131925, Close 133081 (00%) VoM 13411 4
i
® an H’* X
i i s
o we hH.
®
vc 127623
i =
@ o .
» 05 12,400
Iy J o
@ e 12200 | o
oo
o 12000 | 3¢
® ron ] 1 1
iy Warch Aori [E]
o M DI WACD(12,26) = 203 51, S1Gra12,26,0) = 16215
¢ mic 1200 |z
or 600
Vil ST
m T 00
e ] ! leno
Information ROx
= General A [FoI-RaE =T8T
symbol ~DII 8
300
» M1\ Sheet 1 {Sheet2 ), sheet 3 ) sheet 4 ), Sheet 5 ) shee <. 15| o

For Help, press F1 YSE, Group 4, Services, Advertising & Data



.
.

A comparison of the installed list with the component list shows that EK, IP and SBC are no longer constituents of the DJIA  while AIG, PFE and VZ have recently been added (partial list displayed for example use only).
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The obsolete companies can be deleted:
a) successively right click on the three companies within the All Symbols list,
b) select Delete from the context menu that appears.

2.4.2 Download Data For New Symbols
The symbols for companies that have entered the index should now be entered to the database.

Do not enter them to ‘Data’, and then ‘Auto-update’ from within AmiBroker, as this will trigger the default behavior for ‘symbols without quotes’ and download years of  back-fill data. This will create extra quotes that will need to be manually deleted. Use AmiQuote to enter symbols and download to ensure that the date range of the new symbols is aligned to that of the old.

To download using AmiQuote:
a) obtain the start – end dates, for the referenced index ^DJI, using X_Database,
b) leave AmiBroker open with ‘Data’ as the selected database,
c) open AmiQuote and select Add tickers from the AmiQuote toolbar,
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       click here [image: image26.bmp]           
d) type in the new symbols as comma separated text,
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e) enter the From and To dates, to match the referenced index range, and set Yahoo Historical as the source with Automatic import checked,
f) select Start download from the AmiQuote toolbar .
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            click here [image: image29.bmp]        
Data will automatically be downloaded and imported by AmiBroker.
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When the download is complete the database quality check can be repeated using X_Database and the Data Purify tool. The percentage of errors reported should be low and limited to missing quotes.

Discussion on managing missing quotes is not included in this example as it will be covered elsewhere in a separate Users’ Knowledge Base article.

2.5  Refresh The Information Page

2.5.1 Check Symbol Information

Profile data will not be downloaded with the updated price data. To confirm this use the following code to run an Exploration in AA. (The procedure is the same as that used in section 2.1.2 of this article).
/*X_Categories*/
Filter = 1;

AddTextColumn(MarketID(1),"Market");

AddTextColumn(GroupID(1),"Group");

AddTextColumn(SectorID(1),"Sector");

AddTextColumn(IndustryID(1),"Industry");

AddColumn(IsIndex(),"Index",1.0);

AddTextColumn(FullName(),"Full Name");

It can be seen that the new symbols AIG, PFE and VZ do not have all of the information values; there is no ‘Full Name’ and they have defaulted to ‘group 254’ and ‘Advertising/Services’.
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2.5.2 Set Web Research To Yahoo Summary page
The information values should be obtained and entered to the database.

The required data is available for all of the key fields from the Y!F site; most of it from the Profile (Y!Finance) page. The exception is market information which needs to be obtained from the Summary(Y!Finance)  page. This page is not included in the Web Research URL list as installed.
To add the Summary page to Web Research:

a) go to the  http://finance.yahoo.com/ homepage in Internet Explorer,

b) enter AIG into the Enter Symbols > GET QUOTES search box,
c) copy the URL from the web browser address box:

d) click on New in the Web Research settings page,

e) paste the copy into the URL input box,. 
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f) replace the last three initials (AIG), which is a symbol specific address, with {t} which is symbol (or ticker) generic e.g. http://finance.yahoo.com/q?s={t} 
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g) add in a Description of the page for easier identification and close the Customize window.

Next time a Web Research page is opened the Summary page at Y!F will be available to use in Sync mode by selecting it from the scrollable URL list.

The market where the stock is listed is bracketed with the symbol in the top row of the summary pane.
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2.5.2  Enter Symbol Information
The most efficient layout for entering data is to have the Information page in ‘screen length’ view with Web Research open at the relevant page.

If the Information page isn’t available in the Workspace area View > Symbol Information should be checked.

To change the Information page to full length:  

a) ‘left click/hold’ in the title bar and drag it into the Workspace, (a Docking Sticker will appear),

b) hover the pointer over the stickers’ central icon and drop the page there. 
[image: image35.png]imerican International Grou

(B Edt ew Iner Fomat Smbol Amlss Los Wndow e
DEEG S SO OB, s T e ' BRB . L
Symbols 20| wcain)| Thx
Charts | Synbols TAIG - Dally 571172007 Open 72,65, FI 7 ‘njm 8, Close 72,68 (0.5%) Vol 217,207
=0
» ~o1 730
*
 ac
»
88 120
oc
» cat
13
015
I3 Mo
!
’H0
 Hon
@ HPQ
allt
o mic
o
»
@ x0 T 69.0
# Ho
o 1
o 1o
# 1RK
o T
o P
?pe
I3 H,
® T ‘L B7.0
o
o I
o
& 1 arkets
& 01 Groups 660
5 23 sectors
& 03 watchlts
O Favourtes
B Tharch TApril Thiay
TAIG- Volii0 = 217,207 08 240000
220000
rfor 20 x 200,000
= General A 180,000
Symbol 216 P 160,000
Full Name: American International Group, 140,000
Alias ’
Address 120,000
wnry L 100,000
| i
=
» Do\ Sheet 1 /<. ]

0% X

KB D N

e
LB

[0XO)

e

NYSE, Group 254, Financial, Insurance (Pror





Alternatively if the Chart and Symbols pages are closed and the Information page is the only Workspace page open, full length view will be the default.

To navigate from one symbol to another  with the Information Page and the Y!F web page in tandem:
a) change the Information page to full screen view,

b) open a New >Web Research page and type/enter a symbol into the Ticker Toolbar box e.g. VZ.
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c) hit enter and the current AmiBroker browser page will open to VZ.

Scroll through the list collecting and entering data for each symbol.

(Note that the Ticker Toolbar acts like a search tool and finds VZ in the list. If a symbol is only partially entered the Ticker Toolbar will find the nearest match. For short lists the symbol can easily be selected from the drop down, or all symbols can be scrolled using the up/down arrow keys).
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To enter the values:

a) click on the tabbed Information page,

b) select the cell,

c) type the values into the cell and enter them or select an option from the cell’s drop down box where applicable. 

Copy from the browser and paste into the cell can also be used if the browser text is not linked.

(Note that the industry listings in the Information page dropdowns may be different from those in Yahoo. If this is the case use the closest available description. Sector classifications are not entered as they automatically default to the sector where the industry has membership. As group classification was not part of the example set-up do not enter any group information. Group 254 will remain as the default for new symbols for this database).
After entering all of the values for each symbol, if the X_Categories Exploration is repeated, all symbols will now be reported with values in all of the key information fields.
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2.6  Download Fundamental Data

Fundamental data can also be downloaded for these symbols by using AmiQuote.

Refer to ‘AmiBroker Help > Help Contents > Tutorial > User Interface’ for instructions.

3.0 Conclusion
This completes the tutorial. The database has been updated with current components, data and information in all key fields. (Note that this is a basic example intended to introduce new users to a range of AmiBroker features. Intermediate and advanced methods of refreshing databases, including additional fields, will be considered in future Users’ Knowledge Base articles). Those who followed this tutorial have the option of using the new database or deleting it and restoring the original (as per the instructions at section 1.1).

APPENDIX
Specifications

AmiBroker: 

Standard V4.9 

Amiquote: 
 
V1.94

Time Frame:

Daily

Data Source:

Yahoo

Data Type:

US Stocks

OS:


Windows XP (Home)

Software:

Microsoft Office XP Professional 2002

Browser:

Internet Explorer V7.0

Word Settings
The default view for this document is Normal/Document Map 
To set the document to the default view:

 Note: This will enable the navigation pane which will open at the left side of the document.
a) check Document Map by clicking on it.

b) Click on a heading in the Document Map (navigation pane) to ‘link’ to that section of the document.
To restore the document to Normal wiew:

a) pick View > Normal from the Word menu bar,

b) uncheck Document Map by clicking on it.
